漏洞信息详情

Asylo 缓冲区错误漏洞

  • CNNVD编号:CNNVD-202008-688
  • 危害等级: 超危
  • CVE编号: CVE-2020-8904
  • 漏洞类型: 缓冲区错误
  • 发布时间: 2020-08-12
  • 威胁类型: 远程
  • 更新时间: 2020-08-18
  • 厂        商:
  • 漏洞来源:

漏洞简介

Asylo 0.6.0之前版本中的可信内存存在缓冲区错误漏洞,该漏洞源于‘ecall_restore’函数没有验证output_len指针的范围。攻击者可通过操纵tmp_output_len值利用该漏洞向可信内存的任意位置进行写入操作。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://github.com/google/asylo/commit/e582f36ac49ee11a21d23ad6a30c333092e0a94e

参考网址

来源:CONFIRM

链接:https://github.com/google/asylo/commit/e582f36ac49ee11a21d23ad6a30c333092e0a94e

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2020-8904

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多