漏洞信息详情

Npm is-my-json-valid 资源管理错误漏洞

  • CNNVD编号:CNNVD-202103-1640
  • 危害等级: 中危
  • CVE编号: CVE-2018-1107
  • 漏洞类型: 资源管理错误
  • 发布时间: 2021-03-29
  • 威胁类型: 远程
  • 更新时间: 2021-10-20
  • 厂        商:
  • 漏洞来源:

漏洞简介

Npm is-my-json-valid是美国Npm公司的一个应用程序。一个JSONSchema使用代码生成机制是非常快速的验证。

is-my-json-valid 存在资源管理错误漏洞,该漏洞源于使用了一个低效的正则表达式来验证定义为电子邮件格式的JSON字段。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://bugzilla.redhat.com/show_bug.cgi?id=1546357

参考网址

来源:MISC

链接:https://bugzilla.redhat.com/show_bug.cgi?id=1546357

来源:MISC

链接:https://snyk.io/vuln/npm:is-my-json-valid:20180214

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2021.3472

来源:packetstormsecurity.com

链接:https://packetstormsecurity.com/files/164555/Red-Hat-Security-Advisory-2021-3917-01.html

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2018-1107

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多