漏洞信息详情

WordPress SQL注入漏洞

  • CNNVD编号:CNNVD-202111-2088
  • 危害等级: 超危
  • CVE编号: CVE-2021-36916
  • 漏洞类型: SQL注入
  • 发布时间: 2021-11-24
  • 威胁类型: 远程
  • 更新时间: 2021-12-03
  • 厂        商:
  • 漏洞来源:

漏洞简介

WordPress是WordPress(Wordpress)基金会的一套使用PHP语言开发的博客平台。该平台支持在PHP和MySQL的服务器上架设个人博客网站。relevant是使用在其中的一个相关内容显示插件。

WordPress 插件存在SQL注入漏洞,该漏洞源于hmwp get user ip函数尝试从多个报头中检索ip地址,包括用户可以欺骗的ip地址报头,例如X-Forwarded-For。因此,在这些IP地址头之一中提供的恶意负载将直接插入SQL查询,从而使SQL注入成为可能。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://patchstack.com/database/vulnerability/hide-my-wp/wordpress-hide-my-wp-premium-plugin-6-2-3-sql-injection-sqli-vulnerability

参考网址

来源:MISC

链接:https://patchstack.com/database/vulnerability/hide-my-wp/wordpress-hide-my-wp-premium-plugin-6-2-3-sql-injection-sqli-vulnerability

来源:CONFIRM

链接:https://codecanyon.net/item/hide-my-wp-amazing-security-plugin-for-wordpress/4177158

来源:MISC

链接:https://patchstack.com/hide-my-wp-vulnerabilities-fixed/

来源:www.cybersecurity-help.cz

链接:https://www.cybersecurity-help.cz/vdb/SB2021120211

来源:nvd.nist.gov

链接:https://nvd.nist.gov/vuln/detail/CVE-2021-36916

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多