漏洞信息详情

Ruby 安全漏洞

  • CNNVD编号:CNNVD-202111-2092
  • 危害等级: 中危
  • CVE编号: CVE-2021-41819
  • 漏洞类型: 其他
  • 发布时间: 2021-11-25
  • 威胁类型:
  • 更新时间: 2021-11-29
  • 厂        商:
  • 漏洞来源:

漏洞简介

Ruby是松本行弘个人开发者的一种跨平台、面向对象的动态类型编程语言。

Ruby 3.0.3之前版本存在安全漏洞,攻击者可利用该漏洞来欺骗cookie名称中的安全前缀,这样就可以欺骗易受攻击的应用程序。

漏洞公告

目前厂商已发布升级补丁以修复漏洞,补丁获取链接:

https://www.ruby-lang.org/en/news/2021/11/24/cookie-prefix-spoofing-in-cgi-cookie-parse-cve-2021-41819/

参考网址

来源:access.redhat.com

链接:https://access.redhat.com/security/cve/cve-2021-41819

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2021.4000

来源:www.auscert.org.au

链接:https://www.auscert.org.au/bulletins/ESB-2021.4002

来源:www.cybersecurity-help.cz

链接:https://www.cybersecurity-help.cz/vdb/SB2021112503

受影响实体

    暂无


漏洞信息快速查询

相关漏洞

更多